Intermittent inbound mail delays

Incident Report for Paubox System Status

Resolved

This incident is now resolved. Any mail that was delayed has been delivered or is delivering now.

Where applicable, a new Inbound Security Mail Log entry with "Delivered" status was created. Please disregard older, duplicate "No Delivery Status Found" mail log entries for the same email due to this issue.
Posted Sep 18, 2025 - 04:52 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 18, 2025 - 04:30 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 18, 2025 - 04:02 UTC

Investigating

We're currently investigating delays for some inbound mail. Customers viewing their Paubox dashboard's Inbound Security Mail Log may see a mix of emails with "Delivered" status and "No Delivery Status Found".
Posted Sep 18, 2025 - 01:32 UTC
This incident affected: Paubox Email Suite (Inbound Security).