Inbound mail delays

Incident Report for Paubox System Status

Resolved

This incident has been resolved. Missing delivery statuses should be updated before the end of the day
Posted Sep 08, 2025 - 16:17 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 08, 2025 - 15:07 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 08, 2025 - 14:03 UTC

Investigating

We are currently investigating this issue.
Posted Sep 08, 2025 - 13:18 UTC
This incident affected: Paubox Email Suite (Inbound Security).