Issues with International 2FA Codes
Incident Report for Paubox System Status
Resolved
This incident has been resolved.
Posted Jul 24, 2023 - 14:36 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 21, 2023 - 21:25 UTC
Investigating
Paubox engineering is currently investigating reported issues around a limited set of users unable to receive 2FA codes to international numbers.
Posted Jul 19, 2023 - 16:29 UTC
This incident affected: Paubox Admin Dashboard.