Paubox Admin Dashboard pages not Loading
Incident Report for Paubox System Status
Resolved
This incident has been resolved.
Posted Jun 21, 2023 - 17:43 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 21, 2023 - 16:26 UTC
Identified
Paubox engineering team has identified a problem with the Paubox Admin Dashboard (including the Paubox Marketing UI) and is working to resolve.
Posted Jun 21, 2023 - 16:07 UTC
This incident affected: Paubox Admin Dashboard and Paubox Marketing.