Mail Delays
Incident Report for Paubox System Status
Resolved
Mail delays, including mail caught in the queue, have cleared up and all systems are operational.
Posted Jun 13, 2023 - 23:38 UTC
Monitoring
Inbound mail queues have returned to normal levels. We are no longer observing delays. We will continue to monitor.
Posted Jun 13, 2023 - 22:39 UTC
Update
We are continuing to investigate this issue.
Posted Jun 13, 2023 - 22:26 UTC
Update
We are continuing to investigate this issue.
Posted Jun 13, 2023 - 22:16 UTC
Investigating
We are currently investigating an issue with inbound mail delays affecting some customers.
Posted Jun 13, 2023 - 21:53 UTC
This incident affected: Paubox Email Suite (Inbound Security).