Some customers reporting mail delays on outbound email

Incident Report for Paubox System Status

Resolved

Functional mail flow has been restored.
Posted 29 days ago. Mar 07, 2025 - 18:16 UTC

Monitoring

A fix has been implemented and we are monitoring results.
Posted 29 days ago. Mar 07, 2025 - 17:14 UTC

Identified

Some customers are reporting delays between 5-20 minutes. We have identified the issue and are working to correct it.
Posted 29 days ago. Mar 07, 2025 - 16:52 UTC
This incident affected: Paubox Email Suite (Outbound Security).