Inbound mail delays reported

Incident Report for Paubox System Status

Resolved

Inbound queues are healthy again. We'll complete an internal post mortem tomorrow and have an RCA available upon request.
Posted Mar 29, 2026 - 22:32 UTC

Update

We are continuing to monitor - the deferred mail queue has dropped ~60% from the highest spike and new mail is flowing. We anticipate full resolution within the hour.
Posted Mar 29, 2026 - 22:09 UTC

Monitoring

A fix is in place and we are monitoring results.
Posted Mar 29, 2026 - 21:35 UTC

Identified

We have identified a database issue and are implementing a fix.
Posted Mar 29, 2026 - 21:18 UTC

Investigating

We are currently investigating inbound mail delays.
Posted Mar 29, 2026 - 21:05 UTC
This incident affected: Paubox Email Suite (Inbound Security).