Users unable to sign into Paubox Admin App
Incident Report for Paubox System Status
Resolved
This incident has been resolved.
Posted Feb 15, 2024 - 21:55 UTC
Monitoring
Access has been restored. We will continue to monitor this issue.
Posted Feb 15, 2024 - 21:27 UTC
Identified
Customers are currently unable to log into our admin app and are receiving 504 errors. We have identified the source of the problem and will work to resolve this as quickly as possible.
Posted Feb 15, 2024 - 21:25 UTC
This incident affected: Paubox Admin Dashboard.