Delivery Delays
Incident Report for Paubox System Status
Resolved
Email volumes have returned to normal and there are no delays detected.
Posted Nov 24, 2021 - 00:57 UTC
Monitoring
Mail volumes have returned back to normal. We will continue to monitor closely.
Posted Nov 23, 2021 - 19:55 UTC
Identified
Paubox is experiencing a higher than usual volume in inbound email which is resulting in delivery delays. All e-mail will be delivered in the order it was received with a delay of about 10-20 minutes.
Posted Nov 23, 2021 - 18:20 UTC
Investigating
We are currently experiencing delays with inbound delivery. Our engineering team is investigating the issue.
Posted Nov 23, 2021 - 17:40 UTC
This incident affected: Paubox Email Suite (Inbound Security).