Some customers reporting mail delays on outbound mail

Incident Report for Paubox System Status

Resolved

Functional mail flow has been restored.
Posted 10 days ago. Apr 08, 2025 - 21:00 UTC

Monitoring

We are monitoring and see improvements in delivery times, resolution pending
Posted 10 days ago. Apr 08, 2025 - 20:32 UTC

Identified

We have identified the issue and are working to correct it.
Posted 10 days ago. Apr 08, 2025 - 19:25 UTC

Investigating

We are currently investigating this issue.
Posted 10 days ago. Apr 08, 2025 - 18:53 UTC
This incident affected: Paubox Email Suite (Outbound Security).