Outbound & Inbound Mail Delays
Incident Report for Paubox System Status
Resolved
Engineering has confirmed all mail queues have returned to normal levels.

We’re no longer seeing any inbound or outbound mail delays and believe the issue to be resolved.
Posted Nov 07, 2023 - 23:11 UTC
Monitoring
At this time, mail queues have returned to normal and there are no outbound mail delays.

We’re still seeing delays for mx1.paubox.com inbound mail currently.
Posted Nov 07, 2023 - 20:04 UTC
Identified
Engineering has identified the cause of delays for inbound and outbound mail and deployed a fix to address this.

At this time, there are no delays for inbound mail routing through mx.paubox.com and mx2.paubox.com.

We’re still seeing delays for mx1.paubox.com inbound mail and all outbound mail currently.
Posted Nov 07, 2023 - 19:13 UTC
Investigating
We are investigating delays in both outbound and inbound mail servers.
Posted Nov 07, 2023 - 17:07 UTC
This incident affected: Paubox Email Suite (Outbound Encrypted Email, Inbound Security).