MX1 Mail Delay affecting limited group of customers
Incident Report for Paubox System Status
Resolved
This incident has been resolved.
Posted Sep 13, 2023 - 05:48 UTC
Monitoring
Changes have been applied to the inbound security pipeline. The engineering team is closely monitoring the results. Delays have been resolved.
Posted Sep 12, 2023 - 19:21 UTC
Identified
Engineering team has identified the cause of the bottleneck leading to slower than usual mail processing time. The root cause is currently being confirmed. Customers on MX1 are experiencing mail delays of ~9 min and falling.
Posted Sep 12, 2023 - 16:46 UTC
Update
While customers on MX1 may be experiencing mail delays up to ~40min, we are seeing the queue recover. We're continuing to investigate.
Posted Sep 12, 2023 - 16:03 UTC
Investigating
We are investigating a mail delay on the MX1 server cluster. Only customers on this cluster have been affected.
Posted Sep 12, 2023 - 14:55 UTC
This incident affected: Paubox Email Suite (Inbound Security) and Hosted Mail.