After thorough investigation we found: - A new log entry was added each time a piece of mail was deferred - “No Delivery Status Found” mail log rows didn’t get updated when the email was later delivered - Instead, a brand new mail log entry with the “Delivered” status was written
Posted Sep 10, 2025 - 19:23 UTC
Update
while we released a fix last night, some customers continue to report missing mail log statuses from Monday 9/8 to Tuesday 9/9 - we are still reviewing these reports
Posted Sep 10, 2025 - 15:06 UTC
Monitoring
A fix has been shipped and we are monitoring results.
Posted Sep 09, 2025 - 22:21 UTC
Identified
Some inbound customers are reporting delays and deferrals on receiving mail. We have identified the cause and are working on a resolution.
Posted Sep 09, 2025 - 18:18 UTC
This incident affected: Paubox Email Suite (Inbound Security).