Mail delays for some customers
Incident Report for Paubox System Status
Resolved
No additional issues have been observed. All systems are operational.
Posted Aug 16, 2023 - 18:02 UTC
Monitoring
Delays have resolved, we are monitoring server health for the next hour.
Posted Aug 16, 2023 - 17:10 UTC
Identified
We have identified a ~20 min mail delay for a limited set of customers. We're in the process of correcting this.
Posted Aug 16, 2023 - 16:43 UTC
This incident affected: Paubox Email Suite (Inbound Security).