Delivery Delays
Incident Report for Paubox System Status
Resolved
This incident has been resolved.
Posted Jun 03, 2021 - 21:54 UTC
Identified
Email is experiencing delays with outbound delivery. No messages have been lost and the system should be caught up shortly.
Posted Jun 03, 2021 - 15:33 UTC
This incident affected: Paubox Email Suite (Outbound Encrypted Email).