New users unable to access their dashboard
Incident Report for Paubox System Status
Resolved
After monitoring throughout the afternoon with no issues, this issue is resolved.
Posted Sep 07, 2023 - 20:20 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 07, 2023 - 18:39 UTC
Investigating
New users who have not previously authenticated with two factor authentication (2FA) are unable to log into their dashboard. Existing users are able to log in without issues.
Posted Sep 07, 2023 - 17:36 UTC
This incident affected: Paubox Admin Dashboard.