8/1 Inbound Mail Delays
Incident Report for Paubox System Status
Resolved
Mail queues have returned to normal and the incident is resolved.
Posted Aug 01, 2023 - 22:36 UTC
Monitoring
Our improvement is live. We'll continue to monitor mail queues.
Posted Aug 01, 2023 - 19:35 UTC
Identified
We are releasing a performance update to inbound security. While mail is flowing, a limited number of customers could still be experiencing mail delays. We will continue to monitor the mail queues until this is resolved.
Posted Aug 01, 2023 - 18:27 UTC
Update
We are continuing to investigate the issue.
Posted Aug 01, 2023 - 16:14 UTC
Investigating
We are currently investigating inbound mail delays.
Posted Aug 01, 2023 - 14:09 UTC
This incident affected: Paubox Email Suite (Inbound Security).