Some Google Workspace customers report inbound & outbound delays on internal emails

Incident Report for Paubox System Status

Resolved

Google has marked this issue resolved.
Posted Apr 08, 2026 - 23:34 UTC

Update

Google has been releasing backed up mail - we expect resolution by 3pm PDT (their resolution estimate).
Posted Apr 08, 2026 - 21:54 UTC

Update

Google has published this https://www.google.com/appsstatus/dashboard/incidents/224ozRqzW4sFBDK8hLnT

We continue to monitor.
Posted Apr 08, 2026 - 20:52 UTC

Update

Google has updated this site with more details: https://support.cloud.google.com/portal/system-status?product=WORKSPACE&cssp=true
We will continue to monitor.
Posted Apr 08, 2026 - 17:56 UTC

Monitoring

We have had a few calls from some Google Workspace customers report inbound & outbound delays on internal emails which Down Dectector corroborates - see https://downdetector.com/status/gmail/ - we will continue to monitor this.
Posted Apr 08, 2026 - 15:32 UTC
This incident affected: Paubox Email Suite (Inbound Security).