Microsoft Office 365 Delivery Delays Impacting Paubox
Incident Report for Paubox System Status
Resolved
The slow connectivity issues surrounding Microsoft Office 365 appear to have subsided. Paubox engineering is no longer seeing delayed mail delivery to Office 365 MX systems.
Posted Aug 09, 2022 - 22:39 UTC
Monitoring
Paubox is aware of mail delivery delays with Microsoft Office 365. Our engineering team and support teams are closely monitoring the situation affecting Microsoft's Office 365 inbound mail systems. Paubox will provide additional status updates as we learn more.
Posted Aug 09, 2022 - 18:27 UTC
This incident affected: Paubox Email Suite (Inbound Security).