Email API 500 Errors
Incident Report for Paubox System Status
Resolved
This incident has been resolved.
Posted Jun 21, 2023 - 16:05 UTC
Investigating
Paubox Email API is currently experiencing temporary 500 errors. Our engineering team is investigating the problem.
Posted Jun 21, 2023 - 14:41 UTC
This incident affected: Paubox Email API.