Inbound mail delays for some customers
Incident Report for Paubox System Status
Resolved
Mail is flowing as expected and all systems are operational.
Posted Aug 18, 2023 - 20:40 UTC
Monitoring
Delay has been reduced to ~30 seconds. We'll continue to monitor.
Posted Aug 18, 2023 - 19:02 UTC
Investigating
Engineering is monitoring ~20 inbound mail delays for some customers. We're expecting the queue will clear within the next hour.
Posted Aug 18, 2023 - 16:59 UTC
This incident affected: Paubox Email Suite (Inbound Security).