Customers unable to access admin panel
Incident Report for Paubox System Status
Resolved
We discovered and resolved an underlying problem with anEC2 instance used to host our database servers. All users are able to access the admin panel as expected.
Posted Aug 15, 2023 - 20:03 UTC
Identified
Access has been restored for most users - you may receive 2 working 2fa codes as an iPhone user. Please contact support if you are still unable to access your dashboard.
Posted Aug 15, 2023 - 14:58 UTC
Investigating
You may be receiving multiple MFA codes - we are investigating this.
Posted Aug 15, 2023 - 14:22 UTC
This incident affected: Paubox Admin Dashboard.