Mail delays for some customers
Incident Report for Paubox System Status
Resolved
The mail delay has been resolved.
Posted Aug 21, 2023 - 19:36 UTC
Monitoring
We are monitoring a traffic spike on one of our inbound server clusters. The queue is currently unspooling and there is a ~10min mail delay.
Posted Aug 21, 2023 - 19:02 UTC
This incident affected: Paubox Email Suite (Inbound Security).