Inbound mail delays for some customers
Incident Report for Paubox System Status
Resolved
Delays have been resolved.
Posted Aug 15, 2023 - 15:59 UTC
Monitoring
Delays have been reduced to ~5m. We'll continue to monitor.
Posted Aug 15, 2023 - 14:59 UTC
Investigating
We are currently investigating this issue.
Posted Aug 15, 2023 - 14:26 UTC
This incident affected: Paubox Email Suite (Inbound Security).