Admin Dashboard Login Difficulties
Incident Report for Paubox System Status
Resolved
This incident has been resolved.
Posted Nov 23, 2021 - 19:55 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 23, 2021 - 17:41 UTC
Investigating
Some customers may experience difficulty logging into or accessing the Paubox Admin Dashboard. Our teams are aware of the issue and working diligently to resolve.
Posted Nov 23, 2021 - 17:09 UTC
This incident affected: Paubox Admin Dashboard.