Outbound mail delay reported by some customers

Incident Report for Paubox System Status

Resolved

Deferred mail has been delivered and the incident is now resolved.
Posted 30 days ago. Mar 06, 2025 - 00:42 UTC

Update

Queue sizes have been reduced 90%; monitoring is ongoing until we observe deferrals have resolved.
Posted 30 days ago. Mar 05, 2025 - 23:40 UTC

Update

We are continuing to monitor for any further issues.
Posted 30 days ago. Mar 05, 2025 - 22:36 UTC

Update

Outbound queues are continuing to drop. We'll continue to monitor until deferred mail is delivered. If you see a "delivery status unknown" in your mail log - very likely it is caught in this delay. Logs should update automatically once queues clear.
Posted 30 days ago. Mar 05, 2025 - 22:36 UTC

Update

New email is flowing normally - email sent from ~11am et until ~3pm et is still unspooling.
Posted 30 days ago. Mar 05, 2025 - 20:34 UTC

Update

Observing significant recovery in outbound queue sizes but delays will continue until they unspool. We will continue to monitor.
Posted 30 days ago. Mar 05, 2025 - 20:23 UTC

Monitoring

We have resolved the root cause of the delay however it will take a few hours for queues to return to normal processing time. We apologize for the inconvenience.
Posted 30 days ago. Mar 05, 2025 - 19:10 UTC

Identified

While some customers report an outbound mail delay in excess of 60 minutes, we have identified the issue and are working on a solution. An additional report has been filed demonstrating ~10 minute delay on Email API.
Posted 30 days ago. Mar 05, 2025 - 17:58 UTC

Investigating

We are currently investigating a mail delay in excess of 10 minutes on our outbound servers.
Posted 30 days ago. Mar 05, 2025 - 16:58 UTC
This incident affected: Paubox Email Suite (Outbound Security).