Platform Login Issues
Incident Report for Paubox System Status
Resolved
Login access is fully restored.
Posted Aug 14, 2023 - 20:51 UTC
Monitoring
We've verified admins are able to log into their dashboards but will continue to monitor this issue.
Posted Aug 14, 2023 - 20:15 UTC
Identified
We are working on a hot fix for this issue.
Posted Aug 14, 2023 - 16:52 UTC
Update
We are continuing to investigate the issue.
Posted Aug 14, 2023 - 14:49 UTC
Investigating
We are investigating issues logging into our admin app.
Posted Aug 14, 2023 - 13:36 UTC
This incident affected: Paubox Admin Dashboard.