Delivery Delays
Incident Report for Paubox System Status
Resolved
Mail delays, including mail caught in the queue, have cleared up and all systems are operational.
Posted May 17, 2023 - 20:40 UTC
Monitoring
Mail queues have returned to normal levels. We are no longer observing significant delays. We will continue to monitor.
Posted May 17, 2023 - 19:32 UTC
Identified
Engineering has identified a bottleneck with our inbound security stack and has temporarily disabled the problematic component.
Posted May 17, 2023 - 16:42 UTC
Update
We are continuing to investigate the issue. More details to follow.
Posted May 17, 2023 - 15:50 UTC
Investigating
We are currently experiencing delays with inbound delivery. Our engineering team is investigating the issue.
Posted May 17, 2023 - 14:37 UTC
This incident affected: Paubox Email Suite (Inbound Security).