Mail Delays for some customers
Incident Report for Paubox System Status
Resolved
This incident has been resolved.
Posted Aug 15, 2023 - 03:05 UTC
Monitoring
While mail servers are operational, the queue is still unspooling and inbound mail flow is still impacted. We'll continue to monitor.
Posted Aug 14, 2023 - 23:08 UTC
Update
During today's event contents of received / delivered mail may have been lost between the hours of ~8am and 12pm ET. We recommend resending and/or requesting contacts resend mail from this time period.
Posted Aug 14, 2023 - 23:05 UTC
Identified
We've discovered a networking problem with our infrastructure provider (AWS) and have taken the necessary steps to address it.
Posted Aug 14, 2023 - 19:55 UTC
Update
We are continuing to investigate the cause of inbound and outbound mail delays. Customers have reported receiving bounce backs and 404 errors. We'll share information on redelivery once we identify the root of the problem.
Posted Aug 14, 2023 - 17:23 UTC
Update
Confirming mail delays are affecting our outbound servers. We are continuing to investigate.
Posted Aug 14, 2023 - 16:07 UTC
Update
We are continuing to investigate this issue.
Posted Aug 14, 2023 - 15:37 UTC
Investigating
We are investigating inbound mail delays.
Posted Aug 14, 2023 - 14:23 UTC
This incident affected: Paubox Email Suite (Outbound Encrypted Email, Inbound Security).